Advanced Excel Training
December 2007

1. Create worksheet of economic data.

A. Import Data — to import data into the current spreadsheet do the following:
a. Click Data on the menu bar.
b. Choose Get External Data.
c. Choose From Web from the submenu.
d

. Enter http://www.regent.edu/admin/stusrv/student_dev/docs/Workshops/Excel_Advanced/USData2000.txt
and click Go.

When the data appears in the New Web Query window, click Import and OK.
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1 [United States Data 2000-2005 1

2 Year 2000 2001 2002 2003 2004 2005

3

4 population 285,003 285,025 291,038 29,043 297,043 300,038

5

6 Total gross domestic product 8,762 9,787 9,953 10,262 10,692 11,066

7

5 Government consumption 1421 1476 1552 1599 1639 1671

9 | Private consumption 6684 681 7,068 7,301 7,585 7,838

10 Gross capital formation 2,023 1833 1,787 1860 2,004 2,127

11 Exports of goods and non-factor services 1,101 1,042 1,018 1,039 1,093 1,141
12 Importsof goods and non-factor services 1,467 1,425 1,472 1537 1629 1,711
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Importing from a text file instead of a webpage would cause the Text Import Wizard to open and

take you through the following steps A-E. (Review these steps as necessary, but the path of this
tutorial continues with Step 2 on page 4.)

Text Import Wizard - Step 1 of 3

The Text Wizard has determined that your data is Delimited.

If this is correct, choose Mext, or choose the data bype that best describes your data.
Criginal data bype
“hoose the file bype that best describes vour data:
() pelimited - Characters such as commas or tabs separate each field.
() Fixed width - Fields are aligned in columns with spaces between each Field,

Start impart at row: |1 % | File arigin: 437 : OEM United States v
Preview of file E:\Regent\Excel 2014Excel 201 Data.bxk,
1l Mmited 3tates Data Z000-Z005000000 N
Z fear0Z0000Z0010Z002Z0Z0030Z0040Z2005
2 000000
4 PopulationdzZ85, 0030288, 0250291 ,0380254, 0430297, 0430300, 038
£ pOooooo L
<

¥

[usas [ ansh |

A Make sure Delimited is the data type that is selected. It is usually the default setting.
B. Click Next.

Text Import Wizard - Step 2 of 3

This screen lets wou sek the delimiters wour daka conkains. You can see how your kext is affected in the preview
belov,

Delimiters
Tab

[ semicolon [ Treat consecutive delimiters as one
[ Cormma Text qualfier: |” v
ext gualifier:

|:| Space

[ other:

Daka preview

nited States Data Z000-2008 -
ear ooa ool ooz 0oz 004 00k
opulation 25,002 88,025 91,038 94,043 £97,043 00,0

w
<

>

el ) [ < ) Cie] [
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C. In Text Import Wizard Step 2, make sure the Delimiter is Tab. Click Next.

Text Import Wizard - Step 3 of 3 E §|
This screen lets wou select each column and set the Data Format,
Column data Format
(%) General
‘General' converts numeric values ko numbers, date values to dates, and all
O Text remaining values to text,
Ouster v
() Do not import column {skip)
Data preview
Cepepral Leperal Cepeprsl Lepergl Depeap
A
EooL EOOE Fooz Eood FO0s
F8a, 025 91,038 94,043 £97,043 [500,0
e
>
’ Cancel ] ’ < Back ]

D. Text Import Step 3 of the wizard allows you to change the data formatting for each
column. Leaving the column data format set to General is a good idea while
importing the data. The data can be changed at any time, if desired. Click Finish.

E.

The last step of the wizard will ask where you want the imported data to be placed.

Where do wou want to put the data?

(%) Existing worksheet:
() Mew warksheet

[F‘[u:uperties... ] [ Ik l [ Zancel ]

The default choice is cell Al of the current worksheet. Since we don’t have any

other information in our worksheet, we would click OK to place the data at the
top left corner of our spreadsheet.
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The data would be placed in the appropriate cells of the spreadsheet beginning at Al.
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1 [United States Data 2000-2005 |

2 Year 2000 2001 2002 2003 2004 2005

B]

4 Ppopulation 285,003 288,025 291,038 294,043 297,043 300,038

5

6 Total gross domestic product 9,762 9,787 9,953 10,262 10,692 11,066

7 =
8  Government consumption 1,421 1,476 1,552 1,599 1,639 1,671

9 | Private consumption 6,684 6,861 7,068 7301 7,585 7,838

10 Gross capital formation 2,023 1,833 1,787 1,860 2,004 2,127

11  Exports of goods and non-factor services 1,101 1,042 1,018 1039 1,093 1,141

12 Imports of goods and non-factor services 1,467 1,425 1,472 1537 1629 1,711

13

14

15

16

17

M 4 » M| Sheetl - Sheet2 , Sheetd ~ ¥J E. m

Ready

74 start E-CRBEED

2. Auto-format the table

To auto format the table we will work from a copy. To duplicate the table by creating a copy of
the sheet you must:

v" Right click the Sheetl tab.
v Choose Move or Copy.

7
8  Government consumption
9  Private consumption

10 Gros In;;n..‘ i “ion
11 Expg | Delete 1 non-fact
12| Impq | B d non-fact
Move or Copy...
13 QJ View Code
14 .'ij_‘ Protect Sheet...
Tab Colo >
15 = :
Hide
16
Select All Sheets
M 4 » M| Sheetr=smeerzr=sneees~ 7]

Ready
‘4 start E-CBEED &
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v" Click the Create a copy check box.
v Click OK.

Move or Copy

Maove selected sheets
To book;

|Eu:u:|k5

Before sheet;
Sheetl
Sheetz
Sheet3

(move ko end)

I Ok l[ Cancel ]

The new sheet will be temporarily called Sheetl (2) until a name is assigned. Double click the
tab name to select it, type AutoFormat, then press Enter.

12 Imports of goods and
33
14
15
16

7
4 4 » M| Sheetl (2) - Sheetl - Sheet2
Ready

Jstat E - BEE@

Next, set the column widths for B-G at 12 characters:

v" Select columns B-G.

v" From the Cells menu on the Home tab, select Format > Column Width.
v' Enter “12” in the Column Width dialog box and click OK.

Column Width  [2|[X]

Colurnm width: | e

Ok ][ Cancel ]
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To Format the data:

Select Row 1 (A1:G1).

On the Home tab’s scrolling Style menu, use the down arrow to scroll down to the
Heading 1 option and select Heading 1.

Select Row 2 (A2:G2).

On the Home tab’s scrolling Style menu, select Heading 2.

Select Rows 4 through 12 (A4:G12). NOTE: A new row 3 will be automatically inserted.

v
v

AN NI NN

On the Home tab’s Style menu, click on Format as Table, and select Table Style Light
16. Click OK on the Format as Table dialog box that opens, and click Yes when the
message appears, Your selection overlaps... Do you want to convert...?

Right click on the number 3 at the left margin of row 3 and select Hide.

<

o9~ i Books [Compatibility Mode] - Microsoft Excel Table Tools
H

D)
=2 ome  Insert  Pagelayout  Formulas Data  Review | View Design @ -°
Il Page Break Preview | FomuiaBar | 7 New Window Espit | 11| 3
’j‘l 5] cust i 9| Headings = L\J gAnang:Al\ —tae | —H % j
o e (3 Fulsreen Message Bar oo o | Frecze Panes ~ (] Unhide | 413 | worsspace windows~ || e
Workbook Views ShowHide Zoom Window Macros
[ na - fe | Population
A B c D E F G K
1 United States Data 2000-2005
2 Year 2000 2001 2002 2003 2004 2005
4 |Population 285,003 288,025 291,038/ 294,043 297,043 300,038
5
6 Total gross domestic product 9,762 9,787 9,953 10,262 10,692 11,066
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10  Gross capital formation 2,023 1,833 1,787, 1,860 2,004 2,127||=
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3. Change cell formats to include dollar signs ($) where needed.

v' Select cells (B6:G12).

v" On the Home tab’s Cells menu, click on Format, and then Format Cells.

v From the Number tab, choose Currency, change decimal places to 0, and change
negative numbers to show in parentheses.

v" Click OK.

Format Cells

1 234
($1,234)

Currency formats are used for general monetary values. Use Accounting Formats to

slign decimal points in a column,
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1 United States Data 2000-2005

2 Year 2000 2001 2002 2003 2004 2005
4 population 285,003 288,025 291,038 294,043 297,043 300,038

5

6 Total gross d ic product 59,762 9,787 59,953 510,262 $10,692 $11,066

7

8 | Government consumption $1,421 $1,476 $1,552 $1,599 $1,639 $1,671

9 Private consumption 56,684 56,861 $7,068 57,301 57,585 57,838
10| Gross capital formation $2,023 $1,833 $1,787 $1,860 $2,004 $2,127 ||=
11 Exports of goods and non-factor services 51,101 51,042 $1,018 $1,039 51,093 51,141

12 Imports of goods and non-factor services 51,467 51,425 $1,472 $1,537 51,629 51,711
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4. In cell A6 (Total Gross Domestic Product) add "In billions of constant 2000 U.S. dollars™
as a comment:

v Click on cell A6 to select it.
v Right click the cell and choose Insert Comment from the menu.
v’ Delete any text from the comment box, if applicable.
v Type In Billions of Constant US dollars.
v Click on another cell to close the comment box.
285,003 288,025
<7 Regent I.Inf:ers'lty: 7
imestic product In Billions of Constant US £/87 |
dollars
:consumption 476 |
umption A ;861 o
| formation $2,023 $1,833
oods and non-factor services . $1,101 51,042
oods and non-factor services $1,467 $1,425

When the mouse pointer is positioned over the red triangle in the upper right corner of the cell,
the comment will appear.

5. Set a formula to calculate year to year growth.

v' Insert a blank row after Total Gross Domestic Product (row 6).
o Rightclick in row 7.
o Select Insert.
o Select Entire Row on the Insert menu that appears, and click OK.
v Incell A7, enter GDP Year to Year Growth.
v Select cell C7. On the Home tab’s Cell menu, click on Format and select Format Cells.
o Select Percentage, 2 decimal places, and OK.
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Format Cells E| fgl

| Alignment Font Baorder Fill Pratection

Category:
General Sample
Mumber 0.26%
Currency
Accounting
Date

Decimal places: |2 Es

Fraction
Soientific
Texk
Special
Custom

Petcentage formats multiply the cell value by 100 and displays the result with a percent
symbal,

{ OF. ][ Cancel ]

v In cell C7, enter the following formula: =(C6-B6)/C6 and press Enter.
o This will calculate the percentage of increase between 2001 and 2000.

v" Drag the formula in cell C7 to the right to copy it by placing your mouse pointer on the
bottom right corner of the cell, clicking and holding the left mouse button, and dragging
over to G7. (When you place your mouse pointer on the bottom right corner of C7 it must
be a black “+” in order to copy the formula correctly.)
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Y[ vome | mcet  pagelsyout  Formuas Dsts Rewew  view ©-=x
= ” 7| G°nset- | E -
Bl KB I 2 i
" e[S St S G| G- | o L R
ipboard = jumber & Styles Cells Editing

c D E F G 5
1 United States Data 2000-2005
2 Year 2000 2001 2002 2003 2004 2005
4 Population 285,003 288,025 291,038 294,043 297,043 300,038
5
6 Total gross domestic product $9,762 $9,787 $9,953 $10,262 $10,692 $11,066
7 GDPYear to Year Growth 0.26% 1.67% 3.01% 4.02% 3.38%
8
9 Government consumption $1,421 $1,476 $1,552 $1,599 $1,639 $1,671
10 | Private consumption 56,684 $6,861 $7,068 $7,301 $7,585 57,838 ||=
11| Gross capital formation $2,023 $1,833 $1,787 $1,860 $2,004 $2,127
12 | Exports of goods and non-factor services 51,101 $1,042 $1,018 $1,039 $1,093 51,141
13 Imports of goods and non-factor services $1,467 $1,425 $1,472 $1,537 $1,629 $1,711
14
15
16
17
18
19
20
21
i@ ¥ | AutoFormat Sheetl . Shest2  Sheets (2] [ m
=

(8 Micosoft Excel -... | T Excel201-1 [Com... | T Excel 201 - 200;

6. Use conditional formatting to highlight years with growth above 2%. Conditional
formatting allows Excel to change the appearance of data based on certain criteria.

v" Select the row of year to year growth percentages (C7 — G7)
v" On the Home tab’s Styles menu, click on Conditional Formatting, New Rule, and then
Format only cells that contain.
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v" For each condition you set, you will need to fill in the boxes that appear in the Format
only cells with section.
o For Condition 1:

Leave the words cell value in the first box.
Select greater than or equal to in the second box.
Type 2% in the third box.

Set the formatting for bold font with a blue font color.
e Click on the Format button to open the Formal Cell dialog box.

e Click on the Font tab.

e Select Bold under Font style, use the drop-down arrow next to the
Color box to select a blue tone, then click OK.

o For Condition 2:

Leave the words cell value in the first box.

Select less than in the second box.

Type 2% in the third box.

Set the formatting for bold font with a red font color, as in Condition 1,

above.

United States Data 2000-2005

Year

Population

Total gross domestic product
GDPYear to Year Growth

Government consumption

Private consumption

Gross capital formation

Exports of goods and non-factor services
Imports of goods and non-factor services

2000
285,003

$9,762

51,421
56,684
$2,023
51,101
51,467

2001
288,025

$9,787
0.26%

$1,476
56,861
51,833
51,042
51,425

2002
291,038

$9,953
1.67%

51,552
57,068
51,787
51,018
51,472

2003
294,043

$10,262
3.01%

51,599
57,301
51,860
51,039
51,537

2004
297,043

$10,692
4.02%

$1,639
57,585
$2,004
$1,093
51,629

2005
300,038

$11,066
3.38%

51,671
57,838
52,127
51,141
51,711

Step 7. Use absolute references to calculate the percentage of the total gross domestic
product for each year that each line item (A9 — A13) represents.

v Copy the AutoFormat worksheet (see Step 2 on page 3 for instructions).
v Rename the new worksheet GDP Percentages.

v Insert one new column to the right of each year.
o Toinsert a new column after the 2000 column (column B), right click on the C at
the head of Column C.
o Select Insert.
o Repeat for remaining columns.
v Key a percent sign (%) in row 8 for each of the new columns. Align these cells to the
right by selecting them with your cursor, then clicking on the Align Text Right icon on

the Home tab’s Alignment menu.

v" Change Format to percentage with 2 decimals.

Copyright © 2007, Regent University. All rights reserved.
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o On the B tab’s Cells menu, click on Format, and then Format Cells.
o From the Number tab, choose Percentage, and change decimal places to 2.

v In cell C9 enter the formula =B9/$B$6.
v Copy this formula into cells E9, G9, 19, K9, and M9, then “drag” the formula down each
column (as in Step 5 on page 8).
v' Format the entire table again (make sure column width for columns B through M are set
for a width of 12 — see Step 2, page 5).
Al4 - @ £ z g
! & [} c D E F G H 1 J K L M =N |
1 |United States Data 2000-2005 =
2 [Year 2000 2001 2002 2003 2004 2005
4 | Population [ 2e5003] [ 28828 [ 281038 TV [ 29n04 [ 30003
6 | Total gross domestio product N s [ ssmer| | s9s%3] [ swze| | swesz| | smoss |
7 | GDPYearto Yeu Growth 1 x 0.26% b 167 L S - o o
3 | Government consumption | eun| aesex| swrs| ssam|  ewse| s so%|  siow|  1e3sw|  wiews|  le7ew| s | 17a7%)
10 | Private consumption | sess4|  esa7%|  sessl|  70.28%|  $7068|  72.40%|  $7301|  74.79%|  $7565|  77.70%|  $7838|  80.29%|
11 | Gross capialformation | s2023|  2072%| 183 |  1s7e%|  stser|  18.31%|  $1860 |  15.05%|  $2004|  20.53%|  serer|  21.79%|
12 | Exports of goods and non-factor services | $101 | 11.28% $1042 | 10.67%| $1018 | 10.43% | $1039 | 10.64%| $1.093 | 11.20%| $LM1 11.69%|
13 _Imports of s and non-factor services | $1467 | 15.03%| $1.425 | 14.60% | $1472 | 15.08%| $1537 | 15.74%| $1623 | 16.69% $Lm 17.53%,
w [ 1

Step 8.

v
v

Step 9.
v

AN

Freeze panes so that row and column labels are fixed as you scroll.

Click in cell B4.
On the View tab’s Window menu bar click Freeze Panes, and select Freeze Panes.

Create a chart and link it to PowerPoint .

Click the AutoFormat worksheet tab.
o Select cells B2 to G2. Right click and choose Copy
o Rightclick in cell B20 and select Paste Special. In the Paste Special dialog box
that opens, select Values in the Paste section, None in the Operation section,
check the Transpose check box, and click OK.
Copy the Total Gross Domestic Product for each year (B6 to G6) and special paste and
transpose them next to the years (into cell C20, using the same steps as above).
Click on cell B20. Move your cursor to the formula bar and insert an apostrophe before
the number. This tells Excel to treat the value as text instead of as a number. A small
green mark will appear in the corner of the cell when this has been done. Repeat for cells
B21-B25. This is very important when creating a table using the Chart Wizard.
Highlight cells B20 to C25.
On the Insert tab’s Charts menu, click the Column icon and select the 2-D Clustered
Column option.
With the chart still selected, click on the Move Chart button from the Design tab’s
Location menu, and select New Sheet, leaving the sheet labeled Chart 1, and click OK.
On the Design tab’s Data menu, click on Switch Row/Column and Layout 3 from the
Chart Layouts menu, then click on highlight Chart Title and type in Gross Domestic
Product in Billions of Constant 2000 U.S. Dollars.
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‘wEI Dsalise * Books [Compatibility Mode] - Microsoft Excel Chart Tools.
Home  Inset  Pageloyout Formuks  Data  Review  View | Design | layout  Fomat |
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‘Gross Domestic Product in Billions of Constant 2000 U.S. Dollars

s start ECBEED

Copy the chart to PowerPoint.

Click to select the entire chart.

Right click and select copy.

Go to the Start menu and open PowerPoint.

In PowerPoint choose a page in which to paste the chart.
Right click and select Paste. Resize and label slide as desired.

AN NN

' H9-06 )+ Presentation1 [Compatibility Mode] - Microsoft PowerPoint -8 x

Home | Inset  Design  Animations  SideShow  Review  View Cl
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GDP (Bns) -- Constant US Dollars

‘Gross Domestic Product in Billions of Constant 2000 U.S. Dollars

Click to add notes.
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Excel Advanced

Please give us your feedback.
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